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Some Notes on Using Protel Software 
for Schematic Capture and PCB Layout 

 

 
The design of an electronic circuit is a mixture of engineering science, art, and common-sense. One 
must choose a circuit configuration, perform supporting calculations, and select actual electronic 
devices taking into consideration their characteristics, price and availability. The circuit may be 
prototyped, and/or circuit simulation may be performed.  As in all design work, the design process is 
iterative – you need to make initial selections based on your calculations, and then see if they “work”.  

Virtually all electronic circuits that are produced in volume are fabricated on printed circuit boards 
[PCBs, also called printed wire boards, PWBs].  With the introduction of relatively inexpensive ($2k-
$10k), high-quality PCB layout software for personal computers, it is now also common for prototype 
and one-off circuits to be implemented as PCBs.   

When designing an electronic circuit, the selection of components and the physical layout of the 
circuit can, in some cases, be as important as the design of the circuit itself.  An electronic circuit must 
be fabricated from real electronic devices.  Real devices have non-zero physical size and fixed 
terminal positions and sizes. Real devices also have non-ideal electronic characteristics.  
Electromagnetic interference can be a significant problem, particularly for low-noise analogue circuits.  
Signals take a finite time to propagate along the electrical tracks which make the circuit connections.  
This can cause timing problems, particularly if the circuit board is large.  At high frequencies (10s 
MHz-GHz), the conductive tracks behave as transmission lines, with signal reflections occuring where 
circuit impedence changes abruptly.   

Although these effects usually become important for circuits which must operate with very low noise, 
or at high frequency (above 20MHz, say), it is important to appreciate of some of the practical 
problems encountered in circuit layout.   

1 An Overview of Circuit Design and PDB Layout 
1.1 Circuit Schematic Drafting 
A schematic of the circuit is usually sketched first by hand, in order to define the concept and topology 
of the circuit.  As the design is refined, perhaps with the aid of calculations and circuit simulation 
together with information on the price and availability of components, the circuit is often drawn on a 
personal computer or workstation using a schematic editor. This approach has many advantages:  

• the circuit can be drawn in a standardised, clear and neat way which promotes understanding;   
• changes to the component parts or connections can easily be made; 
• some checking of the design can be done automatically – for example, a connection that consists 

only of output pins is probably wrong! 
• the circuit can be exported to a circuit simulation program such as PSpice; 
• a netlist that defines the circuit parts and interconnections can be created for export to a PCB-

layout program; 
• a bill of materials can be created, from which parts can be ordered. 

One important advantage of this approach is that a netlist file can automatically be created.  A netlist is 
simply a list of all of the parts and connections in the circuit.  Each “net” is one electrically continuous 
connection:  for example, all pins that are connected to +5V form one net which is usually designated 
VCC.  When laying out the circuit, the netlist can be imported into a PCB-layout program.  The PCB-
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layout program uses the connectivity information in the netlist, which helps to prevent connection 
errors during manual or automatic track routing.  The bill of materials (BOM) is a convenient list from 
which the components may be ordered. 

1.2 An Overview of PCB Design and Fabrication 
Once the electronic circuit is drawn by hand, or using a schematic editor, the board layout can begin.  
Board layout begins by deciding where to place the components on the board.  Placement is usually 
the most important and difficult step in the layout.  Next, place the tracks to complete the circuit.  
Track routing can be done in a number of different ways.  The easiest, and often the best for simple 
circuits, is to use pencil and 5mm squared paper.  Note that many through-hole components have their 
terminals arranged on a standard 0.1” grid.  A PCB layout program can be used for manual track 
placement (“pad-to-pad routing”), or an autorouter can be used if this facility is provided by the PCB 
layout software.  A netlist produced by circuit drafting software is often a great help in reducing 
connection errors when moving from the schematic to a finalised board layout.   

Once the layout is complete, the board can be fabricated.  In commercial production, this is a 
complicated and involved process that involves a large number (100+) of separate photographic and 
electrochemical processes, together with cutting, drilling, plating, tinning, printing, and testing.   

1.2.1 “Hand-made” PCBs 
With a little1 practice and the correct, fresh materials, simple printed circuit boards can be made by 
hand. With careful registration of the layers, double-sided boards can be made. It is not practical to 
make plated-through holes (PTH), so vias (“vertical” connections between layers) must be made by 
hand-soldering wire links or pins (“matrix pins”) through a board. If multi-layer boards (commercial 
boards may have up to up to 12 conductor layers) with plated-through holes are needed, they will need 
to be fabricated by a commercial PCB manufacturer. 

A simplified production process could begin with laser printing a positive image of the tracks onto 
transparent film, and then photographically transferring the image onto reversal film to make a 
negative image.  This negative is contact-printed onto commercial photo-sensitive coper-clad board 
that has been pre-coated with a photoresist material. To maintain the best image quality, contact 
printing is done with the film emulsion pressed onto the photoresist using glass plates. The photoresist 
is exposed to UV light for 15-40 seconds, depending on the light intensity. The positive image of the 
tracks hardens during photographic developing, and the remainder of the resist can be washed off, 
exposing the copper layer.  All copper which is not protected by the resist layer is then chemically 
etched away, leaving the copper tracks.  The photoresist is then stripped, and the board is trimmed and 
drilled by hand. Before soldering, the copper should be well cleaned (scrubbing with Ajax works 
well), and the boards should be sprayed with PCB lacquer. The lacquer will prevent the copper from 
tarnishing, and can be soldered-through. 

All that remains is to insert the components (“stuff” the board), to solder them into the circuit, and to 
test the completed circuit.  Then you can revise the design, re-do the board layout, make the second 
prototype board, etc... 

1.3 Circuit and PCB Software 
We have licences for a schematic capture program Advanced Schematic and a companion PCB layout 
program Advanced PCB. Both programs were written by an Australian company, Protel2 Pty. Ltd. 
Altium produces some of the world’s most advanced PC-based electronic design automation (EDA) 
tools. Although our licences are for obsolete versions of the programs, they are adequate for simple 
design tasks. Full documentation available as on-line help from within the programs, and some brief 
suggestions for circuit drafting are appended to these notes.  Your design should be based around 
components that are commonly available from electronics hobby stores: 

                                                 
1 A practice little is OK; a lot is much better… 
2 Now Altium Ltd. 
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• David Reid Electronics, http://www.altronics.com.au/ 
• Jaycar Electronics,  http://www.jaycar.com.au/ 
• Dick Smith Electronics,  http://www.dse.com.au/  

or component distributors such as:  
• Farnell  http://www.farnell.com/ 
• RS Components   http://www.rs-components.com.au/ 

The three hobbyist suppliers listed are all in York Street, Sydney – take the train3 to Town Hall 
Station.  Component price and availability should be considered when choosing between alternatives.   

2 Editing Circuit Diagrams with Advanced Schematic 
2.1 Starting the Program 
Start the program from All Programs > Eng > CAD > Protel, and make a new schematic (.sch) file 
in your file space. 

2.2 Part Placement 
A part can only be placed if the library that contains the part is loaded.  Each parts library is equivalent 
to a manufacturer’s data book.  Use Library > Add/Remove  (shortcut is L A) to load a library.  A 
useful library to load is device.lib; it contains common devices such as resistors, capacitors, 
connectors, etc.  The libraries d_something.lib are for compatibility with the DOS version of 
Schematic and should not be used.   

Place a part by Place > Part  (shortcut is P P).  Then type in the component identifier.  Note that 
some parts are identified by manufacturer as well as generic part name:  the identifier 7400 for a TTL 
NAND gate is incorrect, but DM7400 is satisfactory.  DM is one of the prefixes used by National 
Semiconductor.  The book by Horowitz & Hill contains a big list of manufacturers’ prefixes. 

Alternatively, a part can be placed from within the Component Browser.  Open the Component 
Browser by  Options > Component Browser  (shortcut is O B).  Choose the appropriate library and 
find the part by browsing. 

Component types are conventionally designated by letters.  The Australian standard designators are : 
A Assembly, such as an IC, amplifier, box of tricks, etc. 
C Capacitor 
D Digital device - typically an IC 
F Protective device (e.g. fuse) 
L Inductor 
R Resistor 
S Switch 
V Semiconductor (transistor, diode, etc.) 
X Connector or terminal 

For example, R26 would be a resistor.  See  SAA HB3-1986  for more information.  Quite often, U is 
used to designate an IC, and D is used to designate a diode.  Some parts, such as the simple TTL gates,  
have multiple devices within a single part.  The individual devices are designated as U2:A, U2:B, etc.  
That is, U2:A is device A in part U2.  U2:B is the second device (gate) in the part U1.. 

Change the part designator generated by Protel from (for example) U? to U1.  The next U part to be 
placed will then automatically be designated U2 

When placing a part, you can “edit at placement” (when the part outline is shown, indicating that the 
part can be dragged)  by pressing the TAB key.  Otherwise, edit a placed part by double clicking it. 
During placement, SPACEBAR will rorate a part, X or Y will flip it. 

                                                 
3 But make sure that you give it back. 
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Don’t forget to place connectors to allow you to get power and signals into and out of your board! 

2.3 Footprints 
The “footprint” is the physical size, outline, pin location and size, etc. of a part.  Some parts have 
multiple footprints that are defined in Protel’s PCB libraries.  For example, a DM74LS00 NAND gate 
can be supplied in a through-hole DIP14 package, or in a surface-mount SOIC14 package.  Other 
parts, such as resistors, capacitors and switches, have no standard footprint, and so do not have a 
footprint defined in the libraries.  If the schematic is going to be used as the basis for a PCB design, 
you will need to enter an appropriate footprint into the part’s footprint field at part placement.  Some 
useful footprints defined in the Advanced PCB footprint library are shown in the appendix to these 
notes. 

2.3.1 Predefined Footprints 
Note Protel’s names of the standard footprints, which are defined in PFW.LIB.  Open this file from 
within Advanced PCB by using Library > Components to see all the pre-defined footprints.  If a 
footprint that you need is not defined, you will have to create it using Library > Components. 

Note that Protel’s footprints have been known to be wrong. If you are going to build the board, it is 
imperitive that every footprint be checked against the component manufacturers’ specifications. 

2.3.2 User Defined Footprints 
If a part (e.g. an unusual IC) or component package (e.g. a switch) that you need to use is not defined 
in Protel’s libraries, you will have to define it yourself using the Library > Run Library Editor 
command from within Advanced Schematic. 

It is good practice to make pin 1 on each component square for ease of identification; the component 
“footprints” (or “patterns”) provided by Protel follow this convention.  Note that inch measurements 
are commonplace in PCB work.  Most older components have pins which are on a standard 0.100” 
(100 mil) grid. One thousandth of an inch is invariably called a ‘mil’ in PCB work.  The size of a pin is 
not standardised. 

2.4 Place Wires 
Once two or more parts are placed on the schematic, place wires to connect up the pins of parts to 
complete the circuit. Shortcut is P W.  A junction (red dot) indicates that crossing wires are joined.  A 
wire that starts from the end of another wire will be joined to it electrically.  Make sure that wires that 
should not be electrically joined do not have a junction at their crossing point.   

2.5 Net Labels, and Power Pins 
Sometimes a circuit diagram can become messy or confusing if every connection is drawn.  Instead of 
drawing some of the wires in their entirety, a short wire can be drawn from each pin on the net, and a 
net label added to each short wire.  Although there is no wire drawn between pins, the pins are 
electrically connected via the net label. Use Place > Net label  (shortcut is P N) to place a net label. 

Parts in the Protel schematic libraries may have hidden power pins that are automatically connected to 
the nets VCC (+5 Volts) and GND (+0 Volt digital ground).  This convention applies particularly to 
TTL chips4, where the power connections are seldom shown on the schematic.  Protel allows you to 
view the hidden pins, and follows the convention that if you un-hide a hidden pin you have to 
manually make a connection to it. 

2.6 Wiring Tool Bar 
Most of the tools needed for placing parts, wires, net labels, etc. are available on the wiring toolbar. 
(shortcut is O W).  Use “edit at placement” to get variants. 

                                                 
4 74xxxx family parts have power supply at the “top right” pin, and ground at “bottom left”. 
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2.7 Check the Circuit 
Protel has a tool called the electrical rules check (ERC) that checks the connections in your circuit 
against some logical errors, such as a net that only contains output pins.  Run it by File > Reports > 
Electrical Rules Check  (shortcut is F R E).  Eliminate all of the errors.  You can also highlight the 
connections on any particular net by Edit > Select > Net  (shortcut is E S N). To unselect, do by Edit 
> Unselect > All  (shortcut is E E A). 

2.8 Netlist and Bill of Materials  
Can be generated from File > Reports.  The netlist is required for importation into a PCB-layout 
program. 

3 PCB Layout with Advanced PCB 
If you plan on making a PCB “by hand”, design your board using so-called “100 mil” (or “12-
12”) through-hole technology: 

• grid for pin placement 100 mils (2.5 mm); 
• routing grid   25 mils (0.6 mm); 
• minimum track width   12 mils (0.3 mm); 
• minimum track to track clearance   12 mils (0.3 mm); 
• minimum pad size   65 mils  (1.6 mm); 
• minimum via size   50 mils  (1.3 mm); 
• only one track between pads. 

Remember, 1 mil is 0.001 inch, or 0.0254 mm. 

3.1 Starting the Program 
Start the program from All Programs > Eng > CAD > Protel. The first thing that you need to do is to 
get all of the component footprints on the board, and in the best relative positions. 

3.2 Netlist  
Netlist Load  will load the netlist specified, and import the footprints (patterns) associated designated 
for each part.  Note that a component footprint will be found only if the footprint library containing it 
is loaded at the time the netlist is loaded. After the load, there should be no missing patterns, 
components or pins. 

All components will be placed on top of each other.   Select the components, then centre them on your 
board area.  Use  Auto >  Placement Tools > Expand Horizontal and Expand Vertical  to spread 
out the components. 

Then use  Netlist >  Optimise >  All  to re-order the nets in an optimal (shortest path) way.  Next, 
move the components around to get the best layout.  This is the most critical step of the layout.  Don’t 
bother with Auto Place, as it runs very slowly and cannot outperform manual placement. Some 
guidelines that you should follow in placing parts are: 

• Don’t forget that you have to mount the board mechanically somehow. M3 machine screws are 
often used, so place four pads of diameter 6.0 mm and 3.5 mm hole size in the corners of the 
board. 

• place components so that the track routes are short and as straight as possible; 
• place components as close together as possible; 
• but leave sufficient room between components to get the tracks in; 
• all ICs should face the same way, say pin 1 at top left.  Line up components in rows; 
• place connectors, adjustment pots, switches and diagnostic LEDs at or near the board edges. 



6 of 10 

Repeat the  Netlist >  Optimise and component moving steps until you think that the placement is 
satisfactory. 

3.3 Board Dimensions 
Have a guess at the board size - be generous with the size when you begin, as a board that is too small 
will make track routing very difficult. Place a closed rectangle of purple  “keep-out layer” track to 
define the board limits. The keep-out layer is required for the Auto-router to run. 

3.4 Track Routing 
Set up the routing clearances, using Netlist >  Clearances.  For 12-12 technology, set all clearances 
to 5 mil. Then, set up the auto router by Auto >  Setup Auto Route.  Choose, for 12-12 technology 

• routing grid: 25 mil; 
• track width: 12 mil; 
• via size: 50 mil; 
• via hole: 28 mil; 
• Set hugging before 100% (completion), spreading after 100%; 
• Select only the memory and line-probe router passes at this stage.   

Use Auto > Move to Grid to “juggle” the components a little bit so that their pins line up with the 
routing grid.  This step is important, and can have a large effect on the completion percentage.  Make 
sure that the grid that you move to is the same dimension as the grid selected for routing, usually 20 or 
25 mil. 

Then save the board before any track routing is done. 

Then run the auto router, by  Auto > Auto Route > All.   

Then, remove the memory and line-probe passes, and add (say) one maze and one smoothing  pass.  
Run  the auto router again.  Continue until the board is routed satisfactorily, or you decide to give up 
and re-do the component placement and board size. You might want to save the board with a slightly 
different name after each routing pass. 

It is important to note that “auto-routing” is very definitely an iterative manual design process.  The 
quality of the final result depends entirely on the component placement, the track width, pad and via 
sizes chosen, the clearances chosen, the router passes selected, and the number and order of the passes.  
You will have to do a number of layouts to get a reasonable design. 

It will always be necessary to “clean up” the routed board by hand after the auto router has finished. 
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